URI Online Judge | 1043 Triangle (Solution)

Problem Link:
https://www.urionlinejudge.com.br/judge/en/problems/view/1043

URI Online Judge | 1043

Triangle

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Read three point floating values (A, B and C) and verify if is possible to make a triangle with them. If it is possible, calculate the perimeter of the triangle and print the message:

Perimetro = XX.X

If it is not possible, calculate the area of the trapezium which basis A and B and C as height, and print the message:

Area = XX.X

Input

The input file has tree floating point numbers.

Output

Print the result with one digit after the decimal point.
Sample InputSample Output
6.0 4.0 2.0Area = 10.0
6.0 4.0 2.1Perimetro = 12.1
Solution:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
#include <stdio.h>
int main()
{
    double a,b,c;
    scanf("%lf %lf %lf",&a,&b,&c);
    if (a < b + c && b < a + c && c < a + b)
    {
        printf("Perimetro = %.1f\n", a + b + c);
    }
    else
    {
        printf("Area = %.1f\n", c * (a + b) / 2);
    }
    return 0;
}

Comments

Post a Comment

Popular posts from this blog

URI Online Judge | 1036 Bhaskara's Formula (Solution)

URI Online Judge | 1042 Simple Sort (Solution)