URI Online Judge | 1037 Interval (Solution)

Problem Link:
https://www.urionlinejudge.com.br/judge/en/problems/view/1037

URI Online Judge | 1037

Interval

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
The input file contain a float-point number. Your task is to print a message saying in which of following intervals the number belongs: [0,25] (25,50], (50,75], (75,100]. If the input is less than zero or greather than 100, the program must print the message “Fora de intervalo” that means "Out of Interval".
Examples:
[0,25] indicates numbers between 0 and 25.0000, including both.
(25,50] indicates numbers greather than 25 (25.00001) up to 50.0000000.

Input

The input file contains a floating-point number.

Output

The output must be a message like following example.
Sample InputSample Output
25.01Intervalo (25,50]
25.00Intervalo [0,25]
100.00Intervalo (75,100]
-25.02Fora de intervalo
Solution:
#include<stdio.h>
int main()
{
    double n;
    scanf("%lf",&n);
    if(n<0 || n>100)
    {
        printf("Fora de intervalo\n");
    }
    else if(n<=25.00)
    {
        printf("Intervalo [0,25]\n");
    }
    else if(n<=50.0)
    {
        printf("Intervalo (25,50]\n");
    }
    else if(n<=75.0)
    {
        printf("Intervalo (50,75]\n");
    }
    else if(n<=100.0)
    {
        printf("Intervalo (75,100]\n");
    }
 
    return 0;
}

Comments

Post a Comment

Popular posts from this blog

URI Online Judge | 1036 Bhaskara's Formula (Solution)

URI Online Judge | 1043 Triangle (Solution)

URI Online Judge | 1042 Simple Sort (Solution)